Altium Designer

Материал из Цезарионии
Перейти к: навигация, поиск

Эта страница заброшена. Наиболее свежая версия — у меня на компьютере.

Эта страница заменяет http://www.caesarion.ru/blog/all/altium-designer/ , та больше обновляться не будет (кроме комментариев).

Сабунин А.Е. Altium Designer Новые решения в проектировании электронных устройств — вот русскоязычная книга. Написана о версии 09, но до сих пор (2017) мало что изменилось.

Так как мне не надо оформлять по ГОСТ, а элементы в основном импортные, то в Sch я работаю в дюймах (был случай, когда переключил на мм, и в итоге одного соединения не оказалось. Потому что провода шли по сетке, а ножки нет, и было место, где визуально провод соединялся с ножкой, а на самом деле нет). А вот в Pcb в мм.

По умолчанию переходные отверстия открыты от паяльной маски. Чтобы закрыть, +Force complete tenting on...

Слои[править]

  • Mechanical1 = центр элемента (но чаще M15), граница платы (в библиотеке элементов)
  • Mechanical13 = STEP-модель (тело элемента), а также границы элемента (тела микросхемы), реперные метки (кружок у первой ножки)
  • Mechanical15 = центр элемента; границы области под элемент (то есть с запасом под паяльник).

Я рисую контур платы в слое Mechanical2, а черновик — в Mechanical3.

Шелкография (overlay) — вещь относительно дорогая, и зачастую, особенно если свободного места много, значительно дешевле сделать плату без неё, а наиболее критичную маркировку (первая ножка микросхемы, +/− питания) выполнить текстом в слое меди.

3 варианта размеров контактных площадок (и свободной области):

  • M = максимум свободного места, ЛУТ, ручной монтаж
  • N = номинал, обычное промышленное производство платы и монтаж
  • L = минимум свободного места, не любое производство справится

https://electronics.stackexchange.com/questions/210702/altium-hide-component-designators-in-fabrication-ourput-gerber

Designator = то, что будет написано шёлком. ? = автонумерация. Пример: R? (сопротивление), U? (микросхема).

Comment = просто так... Можно сделать ссылкой на что-то другое (через = вначале).

Параметры: Value = на схеме будет видно (если галочку поставить).

На PCB можно нарисовать только Designator (по умолчанию включён) и Comment (по умолчанию отключён). Поэтому для всяких резисторов хорошая идея делать Comment="=Value" (если на плате много места, то проще указывать номиналы, чем номера). А для всяких разъёмов можно писать корпус. А для некоторых деталей и номинал, и корпус.

Многоканальные проекты[править]

Задача: к main.SchDoc подключить несколько копий module.SchDoc, причём некоторые выводы одинаковые у всех копий, а некоторые разные.

Примечание: в книге Сабунина описана сама возможность сделать так (и не только так), а вот именно алгоритма у него нет. Так что привожу свой.

Решение: На module.SchDoc ставим порты (Place Port; P, R)на каждый провод (wire), который должен быть доступен извне (замечание: Power Sources имеют глобальную область видимости, их можно просто использовать). Называем порт (например, "Rx"). Всё, с module.SchDoc закончили.

На main.SchDoc ставит символ листа (Sheet Symbol; P, S). Называем его (Designator; для получения 3 копий) "Repeat(MODULE,1,3)", выбираем нужный файл (Filename). Теперь внутри символа листа ставим на каждый провод запись листа (Sheet Entry; P, A). В названии (Name) пишем "Repeat(Rx)" для тех проводов, которые должны быть свои у каждой копии; просто "Rx", если этот провод общий для всех.

Теперь от записи листа выводим провод (wire) и называем его (Net Label; P, N) так же, как в module.SchDoc ("Rx", а не "Repeat(Rx)"). Со второй стороны провода ставим шину (Bus; P, B). От шины делаем выводы (Bus Entry; P, U). А уже эти выводы называем с индексом на конце: "Rx1", "Rx2", "Rx3". Всё!

Правила PCB (Rules)[править]

Открываем PCB. Design → Rules. В правой части Ctrl+A, Del. Закрываем окно и открываем снова — получили правила по умолчанию.

Правим их в соответствии с требованиями завода-изготовителя. ПКМ → Export Rules, Ctrl+A, OK. Получили *.rul-файл.

Теперь для применения своих правил в других проектах достаточно Design → Rules → ПКМ → Import Rules.

Примечание. Для минимизации ошибок производства я создаю более строгие правила (например, минимальный зазор между дорожками 0,3 мм, если завод позволяет 0,2), и лишь если разводка не удаётся, перехожу на более мягкие.

Документация для ручного монтажа[править]

↓↓↓ Это неактуально, есть более правильный способ ↓↓↓
Сначала сделаем Smart PDF только для одной стороны одной платы:
Для печати на чёрно-белом принтере:
Медь, мультислой (он всегда рисуется, даже если якобы удалён) — светло-серые.
Маркировка, паста (либо маска, но тогда будут видны открытые переходные отверстия), контур, слой механики с корпусами — чёрные.
Всё остальное вообще отключить. И расположить правильно (механику выше меди).
Если надо изменить, то 
Когда один pdf отладили, вручную копируем *.OutJob, изменяя его название (было *-top.OutJob, стало *-bottom.OutJob). Подключаем к проекту, редактируем файл *.OutJob → Documentation Output → PCB Prints: меняем название выходного *.pdf, ставим флажок Mirror (вместо flipped в *.Pcb), меняем набор слоёв (top на bottom).
↑↑↑ Это неактуально, есть более правильный способ ↑↑↑

File->Assembly Outputs->Assembly Drawings. Но если нужны настройки (убрать лишние слои, например), то File->New->Output Job File. Assembly Output: удаляем лишнее, для нижнего слоя ставим флажок Mirror. Всё, цвета как раз оптимизированы для чёрно-белого принтера. У Сабунина это раздел 4.15.3.

Список деталей вообще-то делается через Reports->Bill of Materials, но я пишу вручную в текстовом файле:

== <Название платы>-top.pdf ==
=== SMD ===
R1 100 кОм
U1 ATmega16A

=== В отверстие ===
...

== <Название платы>-bottom.pdf ==
=== SMD ===
...

=== В отверстие ===
...

Причём элементы перечисляются как при письме: слева направо, сверху вниз.

Шпаргалка всяких команд[править]

Sheet[править]

Tools->

  • Update form libraries. По умолчанию всё сбросится (номиналы, выбор корпусов), так что надо осторожно выбирать дополнительные настройки.

PCB[править]

Изменение всех выводов одного компонента:

  • Shift-F (Edit → Find Similar Objects)
  • LMB по выводу
  • Component: Any → Same
  • PCB Inspector: меняем Hole Size, X/Y Size...

PcbDoc[править]

  • Свойства страницы → метрическая система
  • Snap Grid
  • Edit → Origin → Set (100, 100)
  • Нарисовать контур платы
  • Выделить контур, Design → Board Shape → Define from selected objects

Sch[править]

Общие выводы многоУГО-компонентов: на всех убираем флажок "Connect To". На первом делаем видимыми ножки. Всё, теперь их можно подключать.